Amiga: IBrowse 2.5.7 Released

Hi,

A new version of IBrowse for Amiga has been released today. 🙂

IBrowse 2.5.7 Released

IBrowse 2.5.7 is now available for download (OS4 users may use AmiUpdate instead), which is the seventh free update for registered owners of IBrowse 2.5. IBrowse 2.1-2.4 and 1.x owners may upgrade to IBrowse 2.5.7 via our store at discounted rates.

Please note: Anybody who was quick and downloaded IBrowse 2.5.7 before 2030 UTC today will have an old javascript.library and should download/install again (the archives have been updated). Also, IBrowse 2.5.7 now requires AmiSSL 5.5, so you are advised to download it before updating IBrowse, otherwise you will be left without HTTPS access.

This is a maintenance release with a few fixes and improvements, including these main changes:

  • Reworked Brotli huffman decoder to avoid triggering a bug on the 68060 processor, which prevented pages from loading
  • Tweaks to the loading of external modules
  • JavaScript improvements
  • Switched to GCC 11, with all warnings enabled, which identified numerous previously unknown bugs which have now been fixed
  • Hundreds of minor internal changes

See the history log or changes list for IBrowse 2.5 for a full breakdown of all the changes made.

https://www.ibrowse-dev.net/news.php?id=1667643221

Great to see that the development of IBrowse continues! This reminds me it is long overdue that I register this program, as I use it on AmigaOS 4.

Thanks for reading, and see you in another post here on Old School Game Blog!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.