List of Compatible Graphics Cards for AmigaOS 4.x

Image by DJNick – Lent from http://www.amiga-look.org/artwork/abstract-v3-hd-wallpaper-nykk-deetronic

Unofficial List of Compatible Graphics Cards for AmigaOS 4.x

Last updated: June 3rd 2020

 

About

This is an unofficial list of graphics cards reported to work under various AmigaOS 4.x configurations.

The aim of this list is to help people find compatible cards for their computers.

I made a big mistake purchasing a graphics card that works perfectly in AmigaOne X5000, but refuses to function properly in Sam460ex. I see others have experienced similar situations, so let us hope that this page will be of help. 🙂

If you want your setup added to the list, please leave a comment below with the following information:

Computer (X1000, X5000, AmigaOne 500 etc) – OSDriver (if any, RadeonHD v1, v2 etc) – Graphics Card

You can also visit the thread I created on Amigaworld.net and post there if you want:

https://amigaworld.net/modules/newbb/viewtopic.php?topic_id=43789&forum=33

Thanks in advance for your help. 🙂

 

Compatible Graphics Cards

Sam460ex – AmigaOS 4.1 FE – RadeonHD v2 – Radeon HD 6450 – Working (User: AmigaOldskooler)
Sam460ex – AmigaOS 4.1 FE – N/A – Radeon HD 7770 – Working (User: Dirkzwager)
Sam460ex – AmigaOS 4.1 FE – N/A – R5 230 – Fails with HDMI, works with VGA. Some games 3D games don’t work and causes the machine to freeze. (User: Dirkzwager)
Sam460ex – AmigaOS 4.x – N/A – R9 255 (Verde) (HP OEM card) (HP 767485-001 767071-001) (Single Slot) – Working (User: Spectre660)
Sam460ex – AmigaOS 4.x – N/A – RX 550 (Polaris) (Sapphire B06ZY7CJF4) – Working, but no U-boot display (User: Spectre660)
Sam460ex – AmigaOS 4.x – N/A – RX 550 (Polaris) (Yeston B07VYR2L43) – Working, but no U-boot display (User: Spectre660)
Sam460ex – AmigaOS 4.x – N/A – RX 560 (Polaris) (Asus STRIX-RX560-4G-GAMING) – Working, but no U-boot display (User: Spectre660)

AmigaOne Micro – AmigaOS 4.1 FE – ATI Radeon 7000 on-board – Working (User: Redfox)

AmigaOne X1000 – AmigaOS 4.1 FE – RadeonHD v3.6 – Radeon R7 250 PCI-e DVI – Working (User: Hypex)
AmigaOne X1000 – N/A – N/A – MSI R9 280 Gaming 3G – Working (User: Rob)

AmigaOne X5000/20 – AmigaOS 4.1 FE – RadeonHD v3.6 – Radeon HD 5450 – Working (User: Gregor)
AmigaOne X5000/20 – AmigaOS 4.1 FE – RadeonHD v3.6 – Radeon R7 240 – Working (Note: Not working with RadeonHD v1.x driver on AmigaOS 4.1 FE installation CD!) (User: Gregor)
AmigaOne X5000/20 – AmigaOS 4.1 FE – RadeonHD v3.7 – Radeon R9 280X – Working (User: Khayoz)

 

 

 

Disclaimer: AmigaOldskooler is not responsible for any errors or omissions, or for the results obtained from the use of this information. The information on this page is provided “as is”, with no guarantee of completeness or accuracy.

4 Comments

  1. X5000/20 – AmigaOS 4.1FE – RadeonHD v3.6 – Radeon HD 5450 – Working

    X5000/20 – AmigaOS 4.1FE – RadeonHD v3.6 – Radeon R7 240 – Working (note: not working with the RadeonHD v1.x driver on OS4.1FE installation CD !)

    Liked by 1 person

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.